linux安装配置jdk

缘起:由于早先的折腾,对linux的环境设置的很乱,我用eclipse编译的文件在不开启eclipse,只用tomcat无法打开,出现了java.lang.UnsupportedClassVersionError的错误,原来是eclipse编译的文件不能在我的低版本的jvm下运行,看来只能升级我的jvm版本了。

下载jdk

可以从官网下载,我的机器是64位版本,可以使用uname-a查看Linux信息,所以选择x64的tar.gz文件,版本是jdk-7u45-linux-x64.tar.gz